Hardware - What Do I Need? << Previous Next >> Contact Us
You will need an Android Phone or Tablet with a Data Plan, a BAFX Products® OBD Reader and a J1939 Converter Cable. We will install our apps on your Android Phone or Tablet and work together with you to ensure the Reader and Cable are attached correctly in your Truck.

Android Phone or Tablet (Minimum Android version supported is 4.4.2 KitKat.)

Android Phone or Android Tablet

BAFX Products® OBD Reader and J1939 Converter Cable

BAFX Reader and J1939 Converter



I'm Ready! - How Do I Start?
PreviousNext